What’s Vulnerable › Vulnerabilities
CVE-2019-18658
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-11-12 · updated 2026-06-17
- Weakness: CWE-59
Description
In Helm 2.x before 2.15.2, commands that deal with loading a chart as a directory or packaging a chart provide an opportunity for a maliciously designed chart to include sensitive content such as /etc/passwd, or to execute a denial of service (DoS) via a special file such as /dev/urandom, via symlinks. No version of Tiller is known to be impacted. This is a client-only issue.
Affected products
- helm: from 2.0.0 before 2.15.2 — fixed in 2.15.2
How to fix
Upgrade to a fixed version: helm 2.15.2. Check the vendor advisory for mitigations.
References
- https://helm.sh/blog/2019-10-30-helm-symlink-security-notice/
- https://helm.sh/blog/2019-10-30-helm-symlink-security-notice/
Get alerted when CVE-2019-18658 or the next vulnerability affects your stack