What’s Vulnerable › Vulnerabilities
CVE-2019-18660
- Severity: medium (CVSS 4.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-11-27 · updated 2026-06-17
- Weakness: CWE-200
Description
The Linux kernel before 5.4.1 on powerpc allows Information Exposure because the Spectre-RSB mitigation is not in place for all applicable CPUs, aka CID-39e72bf96f58. This is related to arch/powerpc/kernel/entry_64.S and arch/powerpc/kernel/security.c.
Affected products
- Canonical Ubuntu Linux: 14.04, 16.04, 18.04, 19.04, 19.10
- Fedoraproject Fedora: 30, 31
- Linux kernel: before 5.4.1 — fixed in 5.4.1
- openSUSE Leap: 15.1
- Red Hat Enterprise Linux: 6.0, 7.0, 8.0
How to fix
Upgrade to a fixed version: Linux kernel 5.4.1. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2019-12/msg00029.html
- http://packetstormsecurity.com/files/155890/Slackware-Security-Advisory-Slackware-14.2-kernel-Updates.html
- http://www.openwall.com/lists/oss-security/2019/11/27/1
- https://access.redhat.com/errata/RHSA-2020:0174
- https://cdn.kernel.org/pub/linux/kernel/v5.x/ChangeLog-5.4.1
- https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit/?id=39e72bf96f5847ba87cc5bd7a3ce0fed813dc9ad
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/LYIFGYEDQXP5DVJQQUARQRK2PXKBKQGY/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/YWWOOJKZ4NQYN4RMFIVJ3ZIXKJJI3MKP/
- https://seclists.org/bugtraq/2020/Jan/10
- https://security.netapp.com/advisory/ntap-20200103-0001/
- https://usn.ubuntu.com/4225-1/
- https://usn.ubuntu.com/4225-2/
Get alerted when CVE-2019-18660 or the next vulnerability affects your stack