What’s Vulnerable › Vulnerabilities
CVE-2019-18667
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-11-02 · updated 2026-06-17
- Weakness: CWE-79
Description
/usr/local/www/freeradius_view_config.php in the freeradius3 package before 0.15.7_3 for pfSense on FreeBSD allows a user with an XSS payload as password or username to execute arbitrary javascript code on a victim browser.
Affected products
- Pfsense-Pkg-Freeradius3: before 0.15.7_3 — fixed in 0.15.7_3
How to fix
Upgrade to a fixed version: Pfsense-Pkg-Freeradius3 0.15.7_3. Check the vendor advisory for mitigations.
References
- https://github.com/pfsense/FreeBSD-ports/commit/30b22b6b0db7b73732a5da346afca66dc244e02a
- https://github.com/pfsense/FreeBSD-ports/commit/30b22b6b0db7b73732a5da346afca66dc244e02a
Get alerted when CVE-2019-18667 or the next vulnerability affects your stack