What’s Vulnerable › Vulnerabilities
CVE-2019-1871: Cisco Integrated Management Controller Buffer Overflow Vulnerability
- Severity: high (CVSS 7.2 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-08-21 · updated 2026-06-17
- Weakness: CWE-119
Description
A vulnerability in the Import Cisco IMC configuration utility of Cisco Integrated Management Controller (IMC) could allow an authenticated, remote attacker to cause a denial of service (DoS) condition and implement arbitrary commands with root privileges on an affected device. The vulnerability is due to improper bounds checking by the import-config process. An attacker could exploit this vulnerability by sending malicious packets to an affected device. When the packets are processed, an exploitable buffer overflow condition may occur. A successful exploit could allow the attacker to implement arbitrary code on the affected device with elevated privileges.
Affected products
- Cisco Integrated Management Controller: from 3.0.0.0 before 3.0\(4k\); from 4.0.0.0 before 4.0\(4b\) — fixed in 3.0\(4k\), 4.0\(4b\)
- Cisco Unified Computing System (Managed): 4.0(1c)hs3
How to fix
Upgrade to a fixed version: Cisco Integrated Management Controller 3.0\(4k\), 4.0\(4b\). Check the vendor advisory for mitigations.
References
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20190821-imc-bo
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20190821-imc-bo
Get alerted when CVE-2019-1871 or the next vulnerability affects your stack