What’s Vulnerable › Vulnerabilities
CVE-2019-18798
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-11-06 · updated 2026-06-17
- Weakness: CWE-125
Description
LibSass before 3.6.3 allows a heap-based buffer over-read in Sass::weaveParents in ast_sel_weave.cpp.
Affected products
- Sass-Lang Libsass: before 3.6.3 — fixed in 3.6.3
How to fix
Upgrade to a fixed version: Sass-Lang Libsass 3.6.3. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2019-18798 or the next vulnerability affects your stack