What’s Vulnerable › Vulnerabilities
CVE-2019-18799
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-11-06 · updated 2026-06-17
- Weakness: CWE-476
Description
LibSass before 3.6.3 allows a NULL pointer dereference in Sass::Parser::parseCompoundSelector in parser_selectors.cpp.
Affected products
- Sass-Lang Libsass: before 3.6.3 — fixed in 3.6.3
How to fix
Upgrade to a fixed version: Sass-Lang Libsass 3.6.3. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2019-18799 or the next vulnerability affects your stack