What’s Vulnerable › Vulnerabilities

CVE-2019-18805

Description

An issue was discovered in net/ipv4/sysctl_net_ipv4.c in the Linux kernel before 5.0.11. There is a net/ipv4/tcp_input.c signed integer overflow in tcp_ack_update_rtt() when userspace writes a very large integer to /proc/sys/net/ipv4/tcp_min_rtt_wlen, leading to a denial of service or possibly unspecified other impact, aka CID-19fad20d15a6.

Affected products

How to fix

Upgrade to a fixed version: Linux kernel 4.14.115, 4.19.38, 4.4.180, 4.9.172. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2019-18805 or the next vulnerability affects your stack