What’s Vulnerable › Vulnerabilities
CVE-2019-18813
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-11-07 · updated 2026-06-17
- Weakness: CWE-401
Description
A memory leak in the dwc3_pci_probe() function in drivers/usb/dwc3/dwc3-pci.c in the Linux kernel through 5.3.9 allows attackers to cause a denial of service (memory consumption) by triggering platform_device_add_properties() failures, aka CID-9bbfceea12a8.
Affected products
- Canonical Ubuntu Linux: 18.04, 19.04, 19.10
- Linux kernel: from 4.19 before 4.19.84; from 4.20 before 5.3.11 — fixed in 4.19.84, 5.3.11
How to fix
Upgrade to a fixed version: Linux kernel 4.19.84, 5.3.11. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=9bbfceea12a8f145097a27d7c7267af25893c060
- https://security.netapp.com/advisory/ntap-20191205-0001/
- https://usn.ubuntu.com/4225-1/
- https://usn.ubuntu.com/4225-2/
- https://usn.ubuntu.com/4226-1/
- https://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=9bbfceea12a8f145097a27d7c7267af25893c060
- https://security.netapp.com/advisory/ntap-20191205-0001/
- https://usn.ubuntu.com/4225-1/
- https://usn.ubuntu.com/4225-2/
- https://usn.ubuntu.com/4226-1/
Get alerted when CVE-2019-18813 or the next vulnerability affects your stack