What’s Vulnerable › Vulnerabilities
CVE-2019-1883: Cisco Integrated Management Controller CLI Command Injection Vulnerability
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-08-21 · updated 2026-06-17
- Weakness: CWE-78
Description
A vulnerability in the command-line interface of Cisco Integrated Management Controller (IMC) could allow an authenticated, local attacker with read-only credentials to inject arbitrary commands that could allow them to obtain root privileges. The vulnerability is due to insufficient validation of user-supplied input on the command-line interface. An attacker could exploit this vulnerability by authenticating with read-only privileges via the CLI of an affected device and submitting crafted input to the affected commands. A successful exploit could allow an attacker to execute arbitrary commands on the device with root privileges.
Affected products
- Cisco Integrated Management Controller: from 3.0.0.0 before 3.0\(4k\); from 4.0.0.0 before 4.0\(4b\); from 4.0.0.0 before 4.0\(2f\) — fixed in 3.0\(4k\), 4.0\(2f\), 4.0\(4b\)
- Cisco Unified Computing System (Managed): 4.0(1c)hs3
How to fix
Upgrade to a fixed version: Cisco Integrated Management Controller 3.0\(4k\), 4.0\(2f\), 4.0\(4b\). Check the vendor advisory for mitigations.
References
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20190821-cimc-cli-inject
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20190821-cimc-cli-inject
Get alerted when CVE-2019-1883 or the next vulnerability affects your stack