What’s Vulnerable › Vulnerabilities
CVE-2019-18834
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2020-07-23 · updated 2026-06-17
- Weakness: CWE-79
Description
Persistent XSS in the WooCommerce Subscriptions plugin before 2.6.3 for WordPress allows remote attackers to execute arbitrary JavaScript because Billing Details are mishandled in WCS_Admin_Post_Types in class-wcs-admin-post-types.php.
Affected products
- WooCommerce Subscriptions: before 2.6.3 — fixed in 2.6.3
How to fix
Upgrade to a fixed version: WooCommerce Subscriptions 2.6.3. Check the vendor advisory for mitigations.
References
- https://woocommerce.com/products/woocommerce-subscriptions/
- https://www.precursorsecurity.com/blog
- https://www.precursorsecurity.com/blog/woocommerce-subscriptions-persistent-xss-cve-2019-18834
- https://woocommerce.com/products/woocommerce-subscriptions/
- https://www.precursorsecurity.com/blog
- https://www.precursorsecurity.com/blog/woocommerce-subscriptions-persistent-xss-cve-2019-18834
Get alerted when CVE-2019-18834 or the next vulnerability affects your stack