What’s Vulnerable › Vulnerabilities
CVE-2019-1884: Cisco Web Security Appliance Web Proxy Denial of Service Vulnerability
- Severity: medium (CVSS 6.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-07-04 · updated 2026-06-17
- Weakness: CWE-20
Description
A vulnerability in the web proxy functionality of Cisco AsyncOS Software for Cisco Web Security Appliance (WSA) could allow an authenticated, remote attacker to cause a denial of service (DoS) condition on an affected device. The vulnerability is due to insufficient input validation mechanisms for certain fields in HTTP/HTTPS requests sent through an affected device. A successful attacker could exploit this vulnerability by sending a malicious HTTP/HTTPS request through an affected device. An exploit could allow the attacker to force the device to stop processing traffic, resulting in a DoS condition.
Affected products
- Cisco Asyncos: from 10.1 before 10.5.5-005; from 11.5 before 11.5.2-020; from 11.7 before 11.7.0-407 — fixed in 10.5.5-005, 11.5.2-020, 11.7.0-407
- Cisco Web Security Appliance (WSA): 10.1.4-017, 10.5.2-072, 11.5.1-fcs-125, 11.7.0-256
How to fix
Upgrade to a fixed version: Cisco Asyncos 10.5.5-005, 11.5.2-020, 11.7.0-407. Check the vendor advisory for mitigations.
References
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20190703-asyncos-wsa
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20190703-asyncos-wsa
Get alerted when CVE-2019-1884 or the next vulnerability affects your stack