What’s Vulnerable › Vulnerabilities
CVE-2019-18848
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-11-12 · updated 2026-06-17
- Weakness: CWE-287
Description
The json-jwt gem before 1.11.0 for Ruby lacks an element count during the splitting of a JWE string.
Affected products
- Debian Linux: 9.0
- Json-Jwt Project Json-Jwt: before 1.11.0 — fixed in 1.11.0
How to fix
Upgrade to a fixed version: Json-Jwt Project Json-Jwt 1.11.0. Check the vendor advisory for mitigations.
References
- https://github.com/nov/json-jwt/commit/ada16e772906efdd035e3df49cb2ae372f0f948a
- https://github.com/nov/json-jwt/compare/v1.10.2...v1.11.0
- https://lists.debian.org/debian-lts-announce/2020/10/msg00001.html
- https://github.com/nov/json-jwt/commit/ada16e772906efdd035e3df49cb2ae372f0f948a
- https://github.com/nov/json-jwt/compare/v1.10.2...v1.11.0
- https://lists.debian.org/debian-lts-announce/2020/10/msg00001.html
Get alerted when CVE-2019-18848 or the next vulnerability affects your stack