What’s Vulnerable › Vulnerabilities
CVE-2019-18853
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-11-11 · updated 2026-06-17
- Weakness: CWE-674
Description
ImageMagick before 7.0.9-0 allows remote attackers to cause a denial of service because XML_PARSE_HUGE is not properly restricted in coders/svg.c, related to SVG and libxml2.
Affected products
- ImageMagick: from 7.0.0-0 before 7.0.9-0 — fixed in 7.0.9-0
How to fix
Upgrade to a fixed version: ImageMagick 7.0.9-0. Check the vendor advisory for mitigations.
References
- https://fortiguard.com/zeroday/FG-VD-19-136
- https://github.com/ImageMagick/ImageMagick/commit/ec9c8944af2bfc65c697ca44f93a727a99b405f1
- https://fortiguard.com/zeroday/FG-VD-19-136
- https://github.com/ImageMagick/ImageMagick/commit/ec9c8944af2bfc65c697ca44f93a727a99b405f1
Get alerted when CVE-2019-18853 or the next vulnerability affects your stack