What’s Vulnerable › Vulnerabilities
CVE-2019-18857
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-11-11 · updated 2026-06-17
- Weakness: CWE-79
Description
darylldoyle svg-sanitizer before 0.12.0 mishandles script and data values in attributes, as demonstrated by unexpected whitespace such as in the javascript	:alert substring.
Affected products
- darylldoyle svg-sanitizer: before 0.12.0 — fixed in 0.12.0
How to fix
Upgrade to a fixed version: darylldoyle svg-sanitizer 0.12.0. Check the vendor advisory for mitigations.
References
- https://github.com/darylldoyle/svg-sanitizer/commit/51ca4b713f3706d6b27769c6296bbc0c28a5bbd0
- https://github.com/darylldoyle/svg-sanitizer/compare/0.11.0...0.12.0
- https://github.com/darylldoyle/svg-sanitizer/commit/51ca4b713f3706d6b27769c6296bbc0c28a5bbd0
- https://github.com/darylldoyle/svg-sanitizer/compare/0.11.0...0.12.0
Get alerted when CVE-2019-18857 or the next vulnerability affects your stack