What’s Vulnerable › Vulnerabilities
CVE-2019-18858
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-11-20 · updated 2026-06-17
- Weakness: CWE-120
Description
CODESYS 3 web server before 3.5.15.20, as distributed with CODESYS Control runtime systems, has a Buffer Overflow.
Affected products
- CODESYS Control for BeagleBone: before 3.5.15.20 — fixed in 3.5.15.20
- CODESYS Control For Empc-A/Imx6: before 3.5.15.20 — fixed in 3.5.15.20
- CODESYS Control for IOT2000: before 3.5.15.20 — fixed in 3.5.15.20
- CODESYS Control For Linux: before 3.5.15.20 — fixed in 3.5.15.20
- CODESYS Control for PFC100: before 3.5.15.20 — fixed in 3.5.15.20
- CODESYS Control for PFC200: before 3.5.15.20 — fixed in 3.5.15.20
- CODESYS Control For Plcnext: before 3.5.15.20 — fixed in 3.5.15.20
- CODESYS Control for Raspberry Pi: before 3.5.15.20 — fixed in 3.5.15.20
- CODESYS Control Rte: before 3.5.15.20 — fixed in 3.5.15.20
- CODESYS Control Runtime System Toolkit: before 3.5.15.20 — fixed in 3.5.15.20
- CODESYS Control Win: before 3.5.15.20 — fixed in 3.5.15.20
- CODESYS Embedded Target Visu Toolkit: before 3.5.15.20 — fixed in 3.5.15.20
- CODESYS Hmi: before 3.5.15.20 — fixed in 3.5.15.20
- CODESYS Remote Target Visu Toolkit: before 3.5.15.20 — fixed in 3.5.15.20
How to fix
Upgrade to a fixed version: CODESYS Control for BeagleBone 3.5.15.20; CODESYS Control For Empc-A/Imx6 3.5.15.20; CODESYS Control for IOT2000 3.5.15.20; CODESYS Control For Linux 3.5.15.20; CODESYS Control for PFC100 3.5.15.20; CODESYS Control for PFC200 3.5.15.20; CODESYS Control For Plcnext 3.5.15.20; CODESYS Control for Raspberry Pi 3.5.15.20; CODESYS Control Rte 3.5.15.20; CODESYS Control Runtime System Toolkit 3.5.15.20; CODESYS Control Win 3.5.15.20; CODESYS Embedded Target Visu Toolkit 3.5.15.20. Check the vendor advisory for mitigations.
References
- https://customers.codesys.com/fileadmin/data/customers/security/2019/Advisory2019-10_CDS-68341.pdf
- https://www.tenable.com/security/research/tra-2019-48
- https://customers.codesys.com/fileadmin/data/customers/security/2019/Advisory2019-10_CDS-68341.pdf
- https://www.tenable.com/security/research/tra-2019-48
Get alerted when CVE-2019-18858 or the next vulnerability affects your stack