What’s Vulnerable › Vulnerabilities
CVE-2019-1886: Cisco Web Security Appliance HTTPS Certificate Denial of Service Vulnerability
- Severity: high (CVSS 8.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-07-04 · updated 2026-06-17
- Weakness: CWE-20
Description
A vulnerability in the HTTPS decryption feature of Cisco Web Security Appliance (WSA) could allow an unauthenticated, remote attacker to cause a denial of service (DoS) condition. The vulnerability is due to insufficient validation of Secure Sockets Layer (SSL) server certificates. An attacker could exploit this vulnerability by installing a malformed certificate in a web server and sending a request to it through the Cisco WSA. A successful exploit could allow the attacker to cause an unexpected restart of the proxy process on an affected device.
Affected products
- Cisco Asyncos: from 10.5 before 10.5.5-005; from 11.5 before 11.5.2-020 — fixed in 10.5.5-005, 11.5.2-020
- Cisco Web Security Appliance (WSA): 10.5.2-072, 10.5.3-025, 11.7.0-fcs-334
How to fix
Upgrade to a fixed version: Cisco Asyncos 10.5.5-005, 11.5.2-020. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/109049
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20190703-wsa-dos
- http://www.securityfocus.com/bid/109049
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20190703-wsa-dos
Get alerted when CVE-2019-1886 or the next vulnerability affects your stack