What’s Vulnerable › Vulnerabilities
CVE-2019-18860
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 5.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-03-20 · updated 2026-06-17
- Weakness: CWE-74
Description
Squid before 4.9, when certain web browsers are used, mishandles HTML in the host (aka hostname) parameter to cachemgr.cgi.
Affected products
- Canonical Ubuntu Linux: 16.04, 18.04, 19.10, 20.04
- Debian Linux: 9.0, 10.0
- openSUSE Leap: 15.1
- Squid: before 4.9 — fixed in 4.9
How to fix
Upgrade to a fixed version: Squid 4.9. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2020-05/msg00018.html
- https://github.com/squid-cache/squid/pull/504
- https://github.com/squid-cache/squid/pull/505
- https://lists.debian.org/debian-lts-announce/2020/07/msg00009.html
- https://usn.ubuntu.com/4356-1/
- https://www.debian.org/security/2020/dsa-4732
- http://lists.opensuse.org/opensuse-security-announce/2020-05/msg00018.html
- http://www.openwall.com/lists/oss-security/2025/11/04/7
- http://www.openwall.com/lists/oss-security/2025/11/05/1
- http://www.openwall.com/lists/oss-security/2025/11/05/7
- https://github.com/squid-cache/squid/pull/504
- https://github.com/squid-cache/squid/pull/505
Get alerted when CVE-2019-18860 or the next vulnerability affects your stack