What’s Vulnerable › Vulnerabilities
CVE-2019-18898: trousers: Local privilege escalation from tss to root
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2020-01-23 · updated 2026-06-17
- Weakness: CWE-59
Description
UNIX Symbolic Link (Symlink) Following vulnerability in the trousers package of SUSE Linux Enterprise Server 15 SP1; openSUSE Factory allowed local attackers escalate privileges from user tss to root. This issue affects: SUSE Linux Enterprise Server 15 SP1 trousers versions prior to 0.3.14-6.3.1. openSUSE Factory trousers versions prior to 0.3.14-7.1.
Affected products
- openSUSE Leap: 15.1
- SUSE Trousers: before 0.3.14-6.3.1; before 0.3.14-7.1 — fixed in 0.3.14-6.3.1, 0.3.14-7.1
How to fix
Upgrade to a fixed version: SUSE Trousers 0.3.14-6.3.1, 0.3.14-7.1. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2020-05/msg00066.html
- https://bugzilla.suse.com/show_bug.cgi?id=1157651
- http://lists.opensuse.org/opensuse-security-announce/2020-05/msg00066.html
- https://bugzilla.suse.com/show_bug.cgi?id=1157651
Get alerted when CVE-2019-18898 or the next vulnerability affects your stack