What’s Vulnerable › Vulnerabilities
CVE-2019-18899: apt-cacher-ng insecure use of /run/apt-cacher-ng
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-01-23 · updated 2026-06-17
- Weakness: CWE-269
Description
The apt-cacher-ng package of openSUSE Leap 15.1 runs operations in user owned directory /run/apt-cacher-ng with root privileges. This can allow local attackers to influence the outcome of these operations. This issue affects: openSUSE Leap 15.1 apt-cacher-ng versions prior to 3.1-lp151.3.3.1.
Affected products
- Apt-Cacher-NG: before 3.1-lp151.3.3.1 — fixed in 3.1-lp151.3.3.1
- openSUSE Backports: sle-15-sp1
How to fix
Upgrade to a fixed version: Apt-Cacher-NG 3.1-lp151.3.3.1. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2020-01/msg00057.html
- http://lists.opensuse.org/opensuse-security-announce/2020-01/msg00065.html
- https://bugzilla.suse.com/show_bug.cgi?id=1157703
- http://lists.opensuse.org/opensuse-security-announce/2020-01/msg00057.html
- http://lists.opensuse.org/opensuse-security-announce/2020-01/msg00065.html
- https://bugzilla.suse.com/show_bug.cgi?id=1157703
Get alerted when CVE-2019-18899 or the next vulnerability affects your stack