What’s Vulnerable › Vulnerabilities

CVE-2019-18900: libzypp stores cookies world readable

Description

: Incorrect Default Permissions vulnerability in libzypp of SUSE CaaS Platform 3.0, SUSE Linux Enterprise Server 12, SUSE Linux Enterprise Server 15 allowed local attackers to read a cookie store used by libzypp, exposing private cookies. This issue affects: SUSE CaaS Platform 3.0 libzypp versions prior to 16.21.2-27.68.1. SUSE Linux Enterprise Server 12 libzypp versions prior to 16.21.2-2.45.1. SUSE Linux Enterprise Server 15 17.19.0-3.34.1.

Affected products

How to fix

Upgrade to a fixed version: SUSE libzypp 16.21.2-2.45.1, 16.21.2-27.68.1, 17.19.0-3.34.1. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2019-18900 or the next vulnerability affects your stack