What’s Vulnerable › Vulnerabilities
CVE-2019-1892: Cisco Small Business Series Switches Memory Corruption Vulnerability
- Severity: high (CVSS 7.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-07-06 · updated 2026-06-17
- Weakness: CWE-119
Description
A vulnerability in the Secure Sockets Layer (SSL) input packet processor of Cisco Small Business 200, 300, and 500 Series Managed Switches could allow an unauthenticated, remote attacker to cause a memory corruption on an affected device. The vulnerability is due to improper validation of HTTPS packets. An attacker could exploit this vulnerability by sending a malformed HTTPS packet to the management web interface of the affected device. A successful exploit could allow the attacker to cause an unexpected reload of the device, resulting in a denial of service (DoS) condition.
Affected products
- Cisco Esw2-350G52Dc Firmware: before 1.4.10.6 — fixed in 1.4.10.6
- Cisco Esw2-550X48Dc Firmware: before 1.4.10.6 — fixed in 1.4.10.6
- Cisco Sf200-24 Firmware: before 1.4.10.6 — fixed in 1.4.10.6
- Cisco Sf200-24P Firmware: before 1.4.10.6 — fixed in 1.4.10.6
- Cisco Sf200-48 Firmware: before 1.4.10.6 — fixed in 1.4.10.6
- Cisco Sf200-48P Firmware: before 1.4.10.6 — fixed in 1.4.10.6
- Cisco Sf300-08 Firmware: before 1.4.10.6 — fixed in 1.4.10.6
- Cisco Sf300-24 Firmware: before 1.4.10.6 — fixed in 1.4.10.6
- Cisco Sf300-24Mp Firmware: before 1.4.10.6 — fixed in 1.4.10.6
- Cisco Sf300-24P Firmware: before 1.4.10.6 — fixed in 1.4.10.6
- Cisco Sf300-24Pp Firmware: before 1.4.10.6 — fixed in 1.4.10.6
- Cisco Sf300-48 Firmware: before 1.4.10.6 — fixed in 1.4.10.6
- Cisco Sf300-48P Firmware: before 1.4.10.6 — fixed in 1.4.10.6
- Cisco Sf300-48Pp Firmware: before 1.4.10.6 — fixed in 1.4.10.6
- Cisco Sf302-08 Firmware: before 1.4.10.6 — fixed in 1.4.10.6
- Cisco Sf302-08Mp Firmware: before 1.4.10.6 — fixed in 1.4.10.6
- Cisco Sf302-08Mpp Firmware: before 1.4.10.6 — fixed in 1.4.10.6
- Cisco Sf302-08P Firmware: before 1.4.10.6 — fixed in 1.4.10.6
- Cisco Sf302-08Pp Firmware: before 1.4.10.6 — fixed in 1.4.10.6
- Cisco Sf500-24 Firmware: before 1.4.10.6 — fixed in 1.4.10.6
- Cisco Sf500-24Mp Firmware: before 1.4.10.6 — fixed in 1.4.10.6
- Cisco Sf500-24P Firmware: before 1.4.10.6 — fixed in 1.4.10.6
- Cisco Sf500-48 Firmware: before 1.4.10.6 — fixed in 1.4.10.6
- Cisco Sf500-48Mp Firmware: before 1.4.10.6 — fixed in 1.4.10.6
- Cisco Sf500-48P Firmware: before 1.4.10.6 — fixed in 1.4.10.6
- Cisco Sg200-18 Firmware: before 1.4.10.6 — fixed in 1.4.10.6
- Cisco Sg200-26 Firmware: before 1.4.10.6 — fixed in 1.4.10.6
- Cisco Sg200-26P Firmware: before 1.4.10.6 — fixed in 1.4.10.6
- Cisco Sg200-50 Firmware: before 1.4.10.6 — fixed in 1.4.10.6
- Cisco Sg200-50P Firmware: before 1.4.10.6 — fixed in 1.4.10.6
How to fix
Upgrade to a fixed version: Cisco Esw2-350G52Dc Firmware 1.4.10.6; Cisco Esw2-550X48Dc Firmware 1.4.10.6; Cisco Sf200-24 Firmware 1.4.10.6; Cisco Sf200-24P Firmware 1.4.10.6; Cisco Sf200-48 Firmware 1.4.10.6; Cisco Sf200-48P Firmware 1.4.10.6; Cisco Sf300-08 Firmware 1.4.10.6; Cisco Sf300-24 Firmware 1.4.10.6; Cisco Sf300-24Mp Firmware 1.4.10.6; Cisco Sf300-24P Firmware 1.4.10.6; Cisco Sf300-24Pp Firmware 1.4.10.6; Cisco Sf300-48 Firmware 1.4.10.6. Check the vendor advisory for mitigations.
References
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20190703-sbss-memcorrupt
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20190703-sbss-memcorrupt
Get alerted when CVE-2019-1892 or the next vulnerability affects your stack