What’s Vulnerable › Vulnerabilities
CVE-2019-18936
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-03-21 · updated 2026-06-17
- Weakness: CWE-674
Description
UniValue::read() in UniValue before 1.0.5 allow attackers to cause a denial of service (the class internal data reaches an inconsistent state) via input data that triggers an error.
Affected products
- Bloq Univalue: before 1.0.5 — fixed in 1.0.5
How to fix
Upgrade to a fixed version: Bloq Univalue 1.0.5. Check the vendor advisory for mitigations.
References
- https://github.com/jgarzik/univalue/compare/v1.0.4...v1.0.5
- https://github.com/jgarzik/univalue/pull/58
- https://github.com/jgarzik/univalue/compare/v1.0.4...v1.0.5
- https://github.com/jgarzik/univalue/pull/58
Get alerted when CVE-2019-18936 or the next vulnerability affects your stack