What’s Vulnerable › Vulnerabilities
CVE-2019-18949
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-11-14 · updated 2026-06-17
- Weakness: CWE-863
Description
SnowHaze before 2.6.6 is sometimes too late to honor a per-site JavaScript blocking setting, which leads to unintended JavaScript execution via a chain of webpage redirections targeted to the user's browser configuration.
Affected products
- Snowhaze: before 2.6.6 — fixed in 2.6.6
How to fix
Upgrade to a fixed version: Snowhaze 2.6.6. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2019-18949 or the next vulnerability affects your stack