What’s Vulnerable › Vulnerabilities
CVE-2019-1895: Cisco Enterprise NFV Infrastructure Software VNC Authentication Bypass Vulnerability
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-08-07 · updated 2026-08-24
- Weakness: CWE-306
Description
A vulnerability in the Virtual Network Computing (VNC) console implementation of Cisco Enterprise NFV Infrastructure Software (NFVIS) could allow an unauthenticated, remote attacker to access the VNC console session of an administrative user on an affected device. The vulnerability is due to an insufficient authentication mechanism used to establish a VNC session. An attacker could exploit this vulnerability by intercepting an administrator VNC session request prior to login. A successful exploit could allow the attacker to watch the administrator console session or interact with it, allowing admin access to the affected device.
Affected products
- Cisco Enterprise NFV Infrastructure Software: before 3.12.1 — fixed in 3.12.1
How to fix
Upgrade to a fixed version: Cisco Enterprise NFV Infrastructure Software 3.12.1. Check the vendor advisory for mitigations.
References
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20190807-nfvis-vnc-authbypass
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20190807-nfvis-vnc-authbypass
Get alerted when CVE-2019-1895 or the next vulnerability affects your stack