What’s Vulnerable › Vulnerabilities

CVE-2019-18956

Description

Divisa Proxia Suite 9 < 9.12.16, 9.11.19, 9.10.26, 9.9.8, 9.8.43 and 9.7.10, 10.0 < 10.0.32, and 10.1 < 10.1.5, SparkSpace 1.0 < 1.0.30, 1.1 < 1.1.2, and 1.2 < 1.2.4, and Proxia PHR 1.0 < 1.0.30 and 1.1 < 1.1.2 allows remote code execution via untrusted Java deserialization. The proxia-error cookie is insecurely deserialized in every request (GET or POST). Thus, an unauthenticated attacker can easily craft a seria1.0lized payload in order to execute arbitrary code via the prepareError function in the com.divisait.dv2ee.controller.MVCControllerServlet class of the dv2eemvc.jar component. allows remote code execution via untrusted Java deserialization. The proxia-error cookie is insecurely deserialized in every request (GET or POST). Thus, an unauthenticated attacker can easily craft a serialized payload in order to execute arbitrary code via the prepareError function in the com.divisait.dv2ee.controller.MVCControllerServlet class of the dv2eemvc.jar component. Affected products include Proxia Premium Edition 2017 and Sparkspace.

Affected products

How to fix

Upgrade to a fixed version: Divisait Dv2Eemvc 18.6.42, 19.0.13, 19.1.19, 19.2.41; Divisait Proxia Phr 1.0.30, 1.1.2; Divisait Proxia Suite 10.0.32, 10.1.5, 9.12.16; Divisait Sparkspace 1.0.30, 1.1.2, 1.2.4. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2019-18956 or the next vulnerability affects your stack