What’s Vulnerable › Vulnerabilities
CVE-2019-18957
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-11-14 · updated 2026-06-17
- Weakness: CWE-79
Description
Microstrategy Library in MicroStrategy before 2019 before 11.1.3 has reflected XSS.
Affected products
- Microstrategy Library: before 11.1.3 — fixed in 11.1.3
How to fix
Upgrade to a fixed version: Microstrategy Library 11.1.3. Check the vendor advisory for mitigations.
References
- http://packetstormsecurity.com/files/155320/MicroStrategy-Library-Cross-Site-Scripting.html
- http://seclists.org/fulldisclosure/2019/Nov/4
- https://seclists.org/bugtraq/2019/Nov/23
- http://packetstormsecurity.com/files/155320/MicroStrategy-Library-Cross-Site-Scripting.html
- http://seclists.org/fulldisclosure/2019/Nov/4
- https://seclists.org/bugtraq/2019/Nov/23
Get alerted when CVE-2019-18957 or the next vulnerability affects your stack