What’s Vulnerable › Vulnerabilities
CVE-2019-18985
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-11-15 · updated 2026-06-17
- Weakness: CWE-307
Description
Pimcore before 6.2.2 lacks brute force protection for the 2FA token.
Affected products
- pimcore/pimcore: before 6.2.2 — fixed in 6.2.2
How to fix
Upgrade to a fixed version: pimcore/pimcore 6.2.2. Check the vendor advisory for mitigations.
References
- https://github.com/pimcore/pimcore/commit/9f2d075243a8392c114d9a8028858b9faf041e2d
- https://github.com/pimcore/pimcore/compare/v6.2.1...v6.2.2
- https://github.com/pimcore/pimcore/commit/9f2d075243a8392c114d9a8028858b9faf041e2d
- https://github.com/pimcore/pimcore/compare/v6.2.1...v6.2.2
Get alerted when CVE-2019-18985 or the next vulnerability affects your stack