What’s Vulnerable › Vulnerabilities
CVE-2019-18986
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-11-15 · updated 2026-06-17
- Weakness: CWE-307
Description
Pimcore before 6.2.2 allow attackers to brute-force (guess) valid usernames by using the 'forgot password' functionality as it returns distinct messages for invalid password and non-existing users.
Affected products
- pimcore/pimcore: before 6.2.2 — fixed in 6.2.2
How to fix
Upgrade to a fixed version: pimcore/pimcore 6.2.2. Check the vendor advisory for mitigations.
References
- https://github.com/pimcore/pimcore/commit/4a7bba5c3f818852cbbd29fa124f7fb09a207185
- https://github.com/pimcore/pimcore/compare/v6.2.1...v6.2.2
- https://github.com/pimcore/pimcore/commit/4a7bba5c3f818852cbbd29fa124f7fb09a207185
- https://github.com/pimcore/pimcore/compare/v6.2.1...v6.2.2
Get alerted when CVE-2019-18986 or the next vulnerability affects your stack