What’s Vulnerable › Vulnerabilities
CVE-2019-19048
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-11-18 · updated 2026-06-17
- Weakness: CWE-401
Description
A memory leak in the crypto_reportstat() function in drivers/virt/vboxguest/vboxguest_utils.c in the Linux kernel before 5.3.9 allows attackers to cause a denial of service (memory consumption) by triggering copy_form_user() failures, aka CID-e0b0cb938864.
Affected products
- Canonical Ubuntu Linux: 18.04, 19.10
- Linux kernel: from 4.16 before 4.19.82; from 4.20 before 5.3.9 — fixed in 4.19.82, 5.3.9
How to fix
Upgrade to a fixed version: Linux kernel 4.19.82, 5.3.9. Check the vendor advisory for mitigations.
References
- https://cdn.kernel.org/pub/linux/kernel/v5.x/ChangeLog-5.3.9
- https://github.com/torvalds/linux/commit/e0b0cb9388642c104838fac100a4af32745621e2
- https://security.netapp.com/advisory/ntap-20191205-0001/
- https://usn.ubuntu.com/4208-1/
- https://usn.ubuntu.com/4226-1/
- https://cdn.kernel.org/pub/linux/kernel/v5.x/ChangeLog-5.3.9
- https://github.com/torvalds/linux/commit/e0b0cb9388642c104838fac100a4af32745621e2
- https://security.netapp.com/advisory/ntap-20191205-0001/
- https://usn.ubuntu.com/4208-1/
- https://usn.ubuntu.com/4226-1/
Get alerted when CVE-2019-19048 or the next vulnerability affects your stack