What’s Vulnerable › Vulnerabilities
CVE-2019-19051
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-11-18 · updated 2026-06-17
- Weakness: CWE-401
Description
A memory leak in the i2400m_op_rfkill_sw_toggle() function in drivers/net/wimax/i2400m/op-rfkill.c in the Linux kernel before 5.3.11 allows attackers to cause a denial of service (memory consumption), aka CID-6f3ef5c25cc7.
Affected products
- Canonical Ubuntu Linux: 14.04, 16.04, 18.04, 19.10
- Debian Linux: 8.0
- Linux kernel: before 5.3.11 — fixed in 5.3.11
- openSUSE Leap: 15.1
How to fix
Upgrade to a fixed version: Linux kernel 5.3.11. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2020-03/msg00021.html
- https://cdn.kernel.org/pub/linux/kernel/v5.x/ChangeLog-5.3.11
- https://github.com/torvalds/linux/commit/6f3ef5c25cc762687a7341c18cbea5af54461407
- https://lists.debian.org/debian-lts-announce/2020/01/msg00013.html
- https://lists.debian.org/debian-lts-announce/2020/03/msg00001.html
- https://security.netapp.com/advisory/ntap-20191205-0001/
- https://usn.ubuntu.com/4225-1/
- https://usn.ubuntu.com/4225-2/
- https://usn.ubuntu.com/4286-1/
- https://usn.ubuntu.com/4286-2/
- https://usn.ubuntu.com/4302-1/
- https://usn.ubuntu.com/4344-1/
Get alerted when CVE-2019-19051 or the next vulnerability affects your stack