What’s Vulnerable › Vulnerabilities
CVE-2019-19053
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-11-18 · updated 2026-06-17
- Weakness: CWE-401
Description
A memory leak in the rpmsg_eptdev_write_iter() function in drivers/rpmsg/rpmsg_char.c in the Linux kernel through 5.3.11 allows attackers to cause a denial of service (memory consumption) by triggering copy_from_iter_full() failures, aka CID-bbe692e349e2.
Affected products
- Broadcom Brocade Fabric Operating System Firmware: all versions
- Canonical Ubuntu Linux: 18.04, 19.10
- Linux kernel: from 4.20 before 5.4.12 — fixed in 5.4.12
- Active IQ Unified Manager for VMware vSphere, Linux, and Microsoft Windows: all versions
- NetApp Aff Baseboard Management Controller: all versions
- NetApp Cloud Backup: all versions
- NetApp Data Availability Services: all versions
- E-Series SANtricity OS Controller Software 11.x: 11.0, 11.0.0, 11.20, 11.25, 11.30, 11.30.5r3 (+12)
- NetApp Fas/Aff Baseboard Management Controller: all versions
- NetApp Hci Baseboard Management Controller: h610s
- NetApp Hci Compute Node Firmware: all versions
- NetApp Solidfire, Enterprise Sds & Hci Storage Node: all versions
- NetApp Solidfire & Hci Management Node: all versions
- NetApp Solidfire Baseboard Management Controller Firmware: all versions
- NetApp Steelstore Cloud Integrated Storage: all versions
How to fix
Upgrade to a fixed version: Linux kernel 5.4.12. Check the vendor advisory for mitigations.
References
- https://github.com/torvalds/linux/commit/bbe692e349e2a1edf3fe0a29a0e05899c9c94d51
- https://security.netapp.com/advisory/ntap-20191205-0001/
- https://usn.ubuntu.com/4300-1/
- https://usn.ubuntu.com/4301-1/
- https://github.com/torvalds/linux/commit/bbe692e349e2a1edf3fe0a29a0e05899c9c94d51
- https://security.netapp.com/advisory/ntap-20191205-0001/
- https://usn.ubuntu.com/4300-1/
- https://usn.ubuntu.com/4301-1/
Get alerted when CVE-2019-19053 or the next vulnerability affects your stack