What’s Vulnerable › Vulnerabilities
CVE-2019-19067
- Severity: medium (CVSS 4.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-11-18 · updated 2026-06-17
- Weakness: CWE-401
Description
Four memory leaks in the acp_hw_init() function in drivers/gpu/drm/amd/amdgpu/amdgpu_acp.c in the Linux kernel before 5.3.8 allow attackers to cause a denial of service (memory consumption) by triggering mfd_add_hotplug_devices() or pm_genpd_add_device() failures, aka CID-57be09c6e874. NOTE: third parties dispute the relevance of this because the attacker must already have privileges for module loading
Affected products
- Canonical Ubuntu Linux: 18.04, 19.04, 19.10
- Linux kernel: before 5.3.8 — fixed in 5.3.8
- openSUSE Leap: 15.1
How to fix
Upgrade to a fixed version: Linux kernel 5.3.8. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2019-12/msg00029.html
- https://bugzilla.suse.com/show_bug.cgi?id=1157180
- https://cdn.kernel.org/pub/linux/kernel/v5.x/ChangeLog-5.3.8
- https://github.com/torvalds/linux/commit/57be09c6e8747bf48704136d9e3f92bfb93f5725
- https://usn.ubuntu.com/4208-1/
- https://usn.ubuntu.com/4226-1/
- https://usn.ubuntu.com/4526-1/
- http://lists.opensuse.org/opensuse-security-announce/2019-12/msg00029.html
- https://bugzilla.suse.com/show_bug.cgi?id=1157180
- https://cdn.kernel.org/pub/linux/kernel/v5.x/ChangeLog-5.3.8
- https://github.com/torvalds/linux/commit/57be09c6e8747bf48704136d9e3f92bfb93f5725
- https://usn.ubuntu.com/4208-1/
Get alerted when CVE-2019-19067 or the next vulnerability affects your stack