What’s Vulnerable › Vulnerabilities
CVE-2019-19075
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-11-18 · updated 2026-06-17
- Weakness: CWE-401
Description
A memory leak in the ca8210_probe() function in drivers/net/ieee802154/ca8210.c in the Linux kernel before 5.3.8 allows attackers to cause a denial of service (memory consumption) by triggering ca8210_get_platform_data() failures, aka CID-6402939ec86e.
Affected products
- Canonical Ubuntu Linux: 16.04, 18.04, 19.04, 19.10
- Linux kernel: from 4.12 before 4.14.151; from 4.15 before 4.19.81; from 4.20 before 5.3.8 — fixed in 4.14.151, 4.19.81, 5.3.8
How to fix
Upgrade to a fixed version: Linux kernel 4.14.151, 4.19.81, 5.3.8. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2019-12/msg00029.html
- https://cdn.kernel.org/pub/linux/kernel/v5.x/ChangeLog-5.3.8
- https://github.com/torvalds/linux/commit/6402939ec86eaf226c8b8ae00ed983936b164908
- https://security.netapp.com/advisory/ntap-20191205-0001/
- https://usn.ubuntu.com/4208-1/
- https://usn.ubuntu.com/4210-1/
- https://usn.ubuntu.com/4226-1/
- http://lists.opensuse.org/opensuse-security-announce/2019-12/msg00029.html
- https://cdn.kernel.org/pub/linux/kernel/v5.x/ChangeLog-5.3.8
- https://github.com/torvalds/linux/commit/6402939ec86eaf226c8b8ae00ed983936b164908
- https://security.netapp.com/advisory/ntap-20191205-0001/
- https://usn.ubuntu.com/4208-1/
Get alerted when CVE-2019-19075 or the next vulnerability affects your stack