What’s Vulnerable › Vulnerabilities
CVE-2019-19078
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 6.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-11-18 · updated 2026-06-17
- Weakness: CWE-401
Description
A memory leak in the ath10k_usb_hif_tx_sg() function in drivers/net/wireless/ath/ath10k/usb.c in the Linux kernel through 5.3.11 allows attackers to cause a denial of service (memory consumption) by triggering usb_submit_urb() failures, aka CID-b8d17e7d93d2.
Affected products
- Canonical Ubuntu Linux: 14.04, 16.04, 18.04, 19.10
- Linux kernel: from 4.14 before 4.14.165; from 4.15 before 4.19.96; from 4.20 before 5.4.12 — fixed in 4.14.165, 4.19.96, 5.4.12
How to fix
Upgrade to a fixed version: Linux kernel 4.14.165, 4.19.96, 5.4.12. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2019-12/msg00029.html
- https://github.com/torvalds/linux/commit/b8d17e7d93d2beb89e4f34c59996376b8b544792
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/D4ISVNIC44SOGXTUBCIZFSUNQJ5LRKNZ/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/MN6MLCN7G7VFTSXSZYXKXEFCUMFBUAXQ/
- https://security.netapp.com/advisory/ntap-20191205-0001/
- https://usn.ubuntu.com/4258-1/
- https://usn.ubuntu.com/4284-1/
- https://usn.ubuntu.com/4287-1/
- https://usn.ubuntu.com/4287-2/
- https://www.oracle.com/security-alerts/cpuApr2021.html
- http://lists.opensuse.org/opensuse-security-announce/2019-12/msg00029.html
- https://github.com/torvalds/linux/commit/b8d17e7d93d2beb89e4f34c59996376b8b544792
Get alerted when CVE-2019-19078 or the next vulnerability affects your stack