What’s Vulnerable › Vulnerabilities
CVE-2019-19079
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-11-18 · updated 2026-06-17
- Weakness: CWE-401
Description
A memory leak in the qrtr_tun_write_iter() function in net/qrtr/tun.c in the Linux kernel before 5.3 allows attackers to cause a denial of service (memory consumption), aka CID-a21b7f0cff19.
Affected products
- Canonical Ubuntu Linux: 18.04
- Linux kernel: from 4.18 before 4.19.89; from 4.20 before 5.3 — fixed in 4.19.89, 5.3
How to fix
Upgrade to a fixed version: Linux kernel 4.19.89, 5.3. Check the vendor advisory for mitigations.
References
- https://cdn.kernel.org/pub/linux/kernel/v5.x/ChangeLog-5.3
- https://github.com/torvalds/linux/commit/a21b7f0cff1906a93a0130b74713b15a0b36481d
- https://security.netapp.com/advisory/ntap-20191205-0001/
- https://usn.ubuntu.com/4258-1/
- https://cdn.kernel.org/pub/linux/kernel/v5.x/ChangeLog-5.3
- https://github.com/torvalds/linux/commit/a21b7f0cff1906a93a0130b74713b15a0b36481d
- https://security.netapp.com/advisory/ntap-20191205-0001/
- https://usn.ubuntu.com/4258-1/
Get alerted when CVE-2019-19079 or the next vulnerability affects your stack