What’s Vulnerable › Vulnerabilities
CVE-2019-19204
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 6.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-11-21 · updated 2026-06-17
- Weakness: CWE-125
Description
An issue was discovered in Oniguruma 6.x before 6.9.4_rc2. In the function fetch_interval_quantifier (formerly known as fetch_range_quantifier) in regparse.c, PFETCH is called without checking PEND. This leads to a heap-based buffer over-read.
Affected products
- Debian Linux: 8.0
- Fedoraproject Fedora: 30, 31
- Oniguruma Project Oniguruma: from 6.0.0 before 6.9.4; 6.9.4-rc1 — fixed in 6.9.4
How to fix
Upgrade to a fixed version: Oniguruma Project Oniguruma 6.9.4. Check the vendor advisory for mitigations.
References
- https://github.com/ManhNDd/CVE-2019-19204
- https://github.com/kkos/oniguruma/issues/162
- https://github.com/kkos/oniguruma/releases/tag/v6.9.4_rc2
- https://github.com/tarantula-team/CVE-2019-19204
- https://lists.debian.org/debian-lts-announce/2019/12/msg00002.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/NO267PLHGYZSWX3XTRPKYBKD4J3YOU5V/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/V3MBNW6Z4DOXSCNWGBLQ7OA3OGUJ44WL/
- https://usn.ubuntu.com/4460-1/
- https://github.com/ManhNDd/CVE-2019-19204
- https://github.com/kkos/oniguruma/issues/162
- https://github.com/kkos/oniguruma/releases/tag/v6.9.4_rc2
- https://github.com/tarantula-team/CVE-2019-19204
Get alerted when CVE-2019-19204 or the next vulnerability affects your stack