What’s Vulnerable › Vulnerabilities
CVE-2019-19246
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-11-25 · updated 2026-06-17
- Weakness: CWE-125
Description
Oniguruma through 6.9.3, as used in PHP 7.3.x and other products, has a heap-based buffer over-read in str_lower_case_match in regexec.c.
Affected products
- Canonical Ubuntu Linux: 14.04
- Debian Linux: 8.0
- Fedoraproject Fedora: 31
- Oniguruma Project Oniguruma: through 6.9.3
- PHP: from 7.3.0 before 7.3.10 — fixed in 7.3.10
How to fix
Upgrade to a fixed version: PHP 7.3.10. Check the vendor advisory for mitigations.
References
- https://bugs.php.net/bug.php?id=78559
- https://github.com/kkos/oniguruma/commit/d3e402928b6eb3327f8f7d59a9edfa622fec557b
- https://lists.debian.org/debian-lts-announce/2019/12/msg00002.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/NO267PLHGYZSWX3XTRPKYBKD4J3YOU5V/
- https://usn.ubuntu.com/4460-1/
- https://bugs.php.net/bug.php?id=78559
- https://github.com/kkos/oniguruma/commit/d3e402928b6eb3327f8f7d59a9edfa622fec557b
- https://lists.debian.org/debian-lts-announce/2019/12/msg00002.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/NO267PLHGYZSWX3XTRPKYBKD4J3YOU5V/
- https://usn.ubuntu.com/4460-1/
Get alerted when CVE-2019-19246 or the next vulnerability affects your stack