What’s Vulnerable › Vulnerabilities
CVE-2019-19271
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-11-26 · updated 2026-06-17
- Weakness: CWE-295
Description
An issue was discovered in tls_verify_crl in ProFTPD before 1.3.6. A wrong iteration variable, used when checking a client certificate against CRL entries (installed by a system administrator), can cause some CRL entries to be ignored, and can allow clients whose certificates have been revoked to proceed with a connection to the server.
Affected products
- ProFTPD: before 1.3.6 — fixed in 1.3.6
How to fix
Upgrade to a fixed version: ProFTPD 1.3.6. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2019-19271 or the next vulnerability affects your stack