What’s Vulnerable › Vulnerabilities

CVE-2019-19312

Description

GitLab EE 8.14 through 12.5, 12.4.3, and 12.3.6 has Incorrect Access Control. After a project changed to private, previously forked repositories were still able to get information about the private project through the API.

Affected products

How to fix

Upgrade to a fixed version: GitLab 12.3.8, 12.4.5, 12.5.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2019-19312 or the next vulnerability affects your stack