What’s Vulnerable › Vulnerabilities

CVE-2019-19325

Description

SilverStripe through 4.4.x before 4.4.5 and 4.5.x before 4.5.2 allows Reflected XSS on the login form and custom forms. Silverstripe Forms allow malicious HTML or JavaScript to be inserted through non-scalar FormField attributes, which allows performing XSS (Cross-Site Scripting) on some forms built with user input (Request data). This can lead to phishing attempts to obtain a user's credentials or other sensitive user input.

Affected products

How to fix

Upgrade to a fixed version: Silverstripe 4.4.5, 4.5.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2019-19325 or the next vulnerability affects your stack