What’s Vulnerable › Vulnerabilities
CVE-2019-19340
- Severity: high (CVSS 8.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-12-19 · updated 2026-06-17
- Weakness: CWE-1188
Description
A flaw was found in Ansible Tower, versions 3.6.x before 3.6.2 and 3.5.x before 3.5.3, where enabling RabbitMQ manager by setting it with '-e rabbitmq_enable_manager=true' exposes the RabbitMQ management interface publicly, as expected. If the default admin user is still active, an attacker could guess the password and gain access to the system.
Affected products
- Tower: from 3.5.0 before 3.5.3; from 3.6.0 before 3.6.2 — fixed in 3.5.3, 3.6.2
- Red Hat Enterprise Linux: 7.0
How to fix
Upgrade to a fixed version: Tower 3.5.3, 3.6.2. Check the vendor advisory for mitigations.
References
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2019-19340
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2019-19340
Get alerted when CVE-2019-19340 or the next vulnerability affects your stack