What’s Vulnerable › Vulnerabilities
CVE-2019-19344
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-01-21 · updated 2026-06-17
- Weakness: CWE-416
Description
There is a use-after-free issue in all samba 4.9.x versions before 4.9.18, all samba 4.10.x versions before 4.10.12 and all samba 4.11.x versions before 4.11.5, essentially due to a call to realloc() while other local variables still point at the original buffer.
Affected products
- Canonical Ubuntu Linux: 16.04, 18.04, 19.04, 19.10
- openSUSE Leap: 15.1
- Samba: from 4.9.0 before 4.9.18; from 4.10.0 before 4.10.12; from 4.11.0 before 4.11.5 — fixed in 4.10.12, 4.11.5, 4.9.18
- Synology Directory Server: all versions
- Synology DiskStation Manager: 6.2
- Synology Router Manager (SRM): 1.2
- Synology Skynas: all versions
How to fix
Upgrade to a fixed version: Samba 4.10.12, 4.11.5, 4.9.18. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2020-01/msg00055.html
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2019-19344
- https://lists.debian.org/debian-lts-announce/2023/09/msg00013.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/4ACZVNMIFQGGXNJPMHAVBN3H2U65FXQY/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/GQ6U65I2K23YJC4FESW477WL55TU3PPT/
- https://security.gentoo.org/glsa/202003-52
- https://security.netapp.com/advisory/ntap-20200122-0001/
- https://usn.ubuntu.com/4244-1/
- https://www.samba.org/samba/security/CVE-2019-19344.html
- https://www.synology.com/security/advisory/Synology_SA_20_01
- http://lists.opensuse.org/opensuse-security-announce/2020-01/msg00055.html
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2019-19344
Get alerted when CVE-2019-19344 or the next vulnerability affects your stack