What’s Vulnerable › Vulnerabilities
CVE-2019-19348
- Severity: high (CVSS 7.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-04-02 · updated 2026-06-17
- Weakness: CWE-266
Description
An insecure modification vulnerability in the /etc/passwd file was found in the container openshift/apb-base, affecting versions before the following 4.3.5, 4.2.21, 4.1.37, and 3.11.188-4. An attacker with access to the container could use this flaw to modify /etc/passwd and escalate their privileges.
Affected products
- Openshift: before 3.11.188-4; from 4.0.0 before 4.1.37; from 4.2.0 before 4.2.21; from 4.3.0 before 4.3.5 — fixed in 3.11.188-4, 4.1.37, 4.2.21, 4.3.5
How to fix
Upgrade to a fixed version: Openshift 3.11.188-4, 4.1.37, 4.2.21, 4.3.5. Check the vendor advisory for mitigations.
References
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2019-19348
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2019-19348
Get alerted when CVE-2019-19348 or the next vulnerability affects your stack