What’s Vulnerable › Vulnerabilities
CVE-2019-19354
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-03-24 · updated 2026-06-17
- Weakness: CWE-266
Description
An insecure modification vulnerability in the /etc/passwd file was found in the operator-framework/hadoop as shipped in Red Hat Openshift 4. An attacker with access to the container could use this flaw to modify /etc/passwd and escalate their privileges.
Affected products
- Red Hat OpenShift Container Platform 4.18: from 4.4 before 4.4.3 — fixed in 4.4.3
How to fix
Upgrade to a fixed version: Red Hat OpenShift Container Platform 4.18 4.4.3. Check the vendor advisory for mitigations.
References
- https://access.redhat.com/articles/4859371
- https://bugzilla.redhat.com/show_bug.cgi?id=1791534
- https://bugzilla.redhat.com/show_bug.cgi?id=1793278
- https://access.redhat.com/articles/4859371
- https://bugzilla.redhat.com/show_bug.cgi?id=1791534
- https://bugzilla.redhat.com/show_bug.cgi?id=1793278
Get alerted when CVE-2019-19354 or the next vulnerability affects your stack