What’s Vulnerable › Vulnerabilities
CVE-2019-19363
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2020-01-24 · updated 2026-06-17
- Weakness: CWE-732
Description
An issue was discovered in Ricoh (including Savin and Lanier) Windows printer drivers prior to 2020 that allows attackers local privilege escalation. Affected drivers and versions are: PCL6 Driver for Universal Print - Version 4.0 or later PS Driver for Universal Print - Version 4.0 or later PC FAX Generic Driver - All versions Generic PCL5 Driver - All versions RPCS Driver - All versions PostScript3 Driver - All versions PCL6 (PCL XL) Driver - All versions RPCS Raster Driver - All version
Affected products
- RICOH Generic Pcl5 Driver: all versions
- RICOH Pc Fax Generic Driver: all versions
- RICOH Pcl6 (Pcl Xl) Driver: all versions
- RICOH Pcl6 Driver For Universal Print: from 4.0 before 4.26 — fixed in 4.26
- RICOH Postscript3 Driver: all versions
- RICOH Ps Driver For Universal Print: from 4.0 before 4.26 — fixed in 4.26
- RICOH Rpcs Driver: all versions
- RICOH Rpcs Raster Driver: all versions
How to fix
Upgrade to a fixed version: RICOH Pcl6 Driver For Universal Print 4.26; RICOH Ps Driver For Universal Print 4.26. Check the vendor advisory for mitigations.
References
- http://jvn.jp/en/jp/JVN15697526/index.html
- http://packetstormsecurity.com/files/156082/Ricoh-Printer-Driver-Local-Privilege-Escalation.html
- http://packetstormsecurity.com/files/156251/Ricoh-Driver-Privilege-Escalation.html
- http://seclists.org/fulldisclosure/2020/Jan/34
- https://www.ricoh.com/info/2020/0122_1/
- http://jvn.jp/en/jp/JVN15697526/index.html
- http://packetstormsecurity.com/files/156082/Ricoh-Printer-Driver-Local-Privilege-Escalation.html
- http://packetstormsecurity.com/files/156251/Ricoh-Driver-Privilege-Escalation.html
- http://seclists.org/fulldisclosure/2020/Jan/34
- https://www.ricoh.com/info/2020/0122_1/
Get alerted when CVE-2019-19363 or the next vulnerability affects your stack