What’s Vulnerable › Vulnerabilities
CVE-2019-19376
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-11-28 · updated 2026-06-17
- Weakness: CWE-20
Description
In Octopus Deploy before 2019.10.6, an authenticated user with TeamEdit permission could send a malformed Team API request that bypasses input validation and causes an application level denial of service condition. (The fix for this was also backported to LTS 2019.9.8 and LTS 2019.6.14.)
Affected products
- Octopus Deploy: before 2019.10.7; from 2019.6.0 before 2019.6.14; from 2019.9.0 before 2019.9.8 — fixed in 2019.10.7, 2019.6.14, 2019.9.8
How to fix
Upgrade to a fixed version: Octopus Deploy 2019.10.7, 2019.6.14, 2019.9.8. Check the vendor advisory for mitigations.
References
- https://github.com/OctopusDeploy/Issues/issues/6005
- https://github.com/OctopusDeploy/Issues/issues/6005
Get alerted when CVE-2019-19376 or the next vulnerability affects your stack