What’s Vulnerable › Vulnerabilities
CVE-2019-1941: Cisco Identity Services Engine Cross-Site Scripting Vulnerability
- Severity: medium (CVSS 6.1 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-07-17 · updated 2026-06-17
- Weakness: CWE-79
Description
A vulnerability in the web-based management interface of Cisco Identity Services Engine (ISE) could allow an unauthenticated, remote attacker to conduct a cross-site scripting (XSS) attack against a user of the web-based management interface of an affected device. The vulnerability exists because the web-based management interface does not properly validate user-supplied input. An attacker could exploit this vulnerability by persuading a user to click a malicious link. A successful exploit could allow the attacker to execute arbitrary script code in the context of the affected interface or access sensitive, browser-based information. At the time of publication, this vulnerability affected Cisco ISE running software releases prior to 2.4.0 Patch 9 and 2.6.0.
Affected products
- Cisco Identity Services Engine: before 2.4.0; 2.4(0.902), 2.4.0-patch_1, 2.4.0-patch_2, 2.4.0-patch_3, 2.4.0-patch_5, 2.4.0-patch_6 (+3) — fixed in 2.4.0
How to fix
Upgrade to a fixed version: Cisco Identity Services Engine 2.4.0. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/109297
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20190717-ise-xss
- http://www.securityfocus.com/bid/109297
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20190717-ise-xss
Get alerted when CVE-2019-1941 or the next vulnerability affects your stack