What’s Vulnerable › Vulnerabilities
CVE-2019-19496
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-12-02 · updated 2026-06-17
- Weakness: CWE-79
Description
Alfresco Enterprise before 5.2.5 allows stored XSS via an uploaded HTML document.
Affected products
- Alfresco: before 5.2.5 — fixed in 5.2.5
How to fix
Upgrade to a fixed version: Alfresco 5.2.5. Check the vendor advisory for mitigations.
References
- https://github.com/vipinxsec/Alfresco_XSS/blob/master/README.md
- https://vipinxsec.blogspot.com/2019/11/alfresco-stored-xss-vulnerability-blind.html
- https://github.com/vipinxsec/Alfresco_XSS/blob/master/README.md
- https://vipinxsec.blogspot.com/2019/11/alfresco-stored-xss-vulnerability-blind.html
Get alerted when CVE-2019-19496 or the next vulnerability affects your stack