What’s Vulnerable › Vulnerabilities
CVE-2019-1952: Cisco Enterprise NFV Infrastructure Software Path Traversal Vulnerability
- Severity: medium (CVSS 6.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-08-08 · updated 2026-08-24
- Weakness: CWE-22
Description
A vulnerability in the CLI of Cisco Enterprise NFV Infrastructure Software (NFVIS) could allow an authenticated, local attacker to overwrite or read arbitrary files. The attacker would need valid administrator privilege-level credentials. This vulnerability is due to improper input validation of CLI command arguments. An attacker could exploit this vulnerability by using directory traversal techniques when executing a vulnerable command. A successful exploit could allow the attacker to overwrite or read arbitrary files on an affected device.
Affected products
- Cisco Enterprise NFV Infrastructure Software: before 3.10.1 — fixed in 3.10.1
How to fix
Upgrade to a fixed version: Cisco Enterprise NFV Infrastructure Software 3.10.1. Check the vendor advisory for mitigations.
References
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20190807-nfv-cli-path
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20190807-nfv-cli-path
Get alerted when CVE-2019-1952 or the next vulnerability affects your stack