What’s Vulnerable › Vulnerabilities

CVE-2019-19527

Description

In the Linux kernel before 5.2.10, there is a use-after-free bug that can be caused by a malicious USB device in the drivers/hid/usbhid/hiddev.c driver, aka CID-9c09b214f30e.

Affected products

How to fix

Upgrade to a fixed version: Linux kernel 3.16.79, 4.14.140, 4.19.68, 4.4.190. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2019-19527 or the next vulnerability affects your stack